RSS Feed

libz.1.2.3.dylib not found in iOS5, XCode 4.2

Posted on

It seems that libz.1.2.3.dylib is not included in iOS5 sdk. Here is simple method to fix this:

1. Open your project in XCode 4.2

2. Remove libz.1.2.3.dylib from framework

3. Add new framework libz.1.2.5

4. Run you app

It works fine. At least for me ;-)

 

!! Enjoy !!

About these ads

About Muzammil

Over the past 4 years, I have designed, developed and managed over 60 iPhone/iPad applications for many large-scale clients, some include Rolex, Ford, Makemark LLC, Source Digital Production, IT City (Kingdom of Saudi Arabia), R.Ø.S.A. Creation etc. These applications ranged from simple navigation bar application to high end user interface design for image processing, simple games with Core Graphics and OpenGL. Before started Triffort Technologies i was working in Ampere Software Pvt Ltd as a senior iOS Developer. I was the first employe of Ampere who started iPhone/iPad development in the company. In ampere i worked on some complex apps like Boxboss, Austin Post, User Tracking etc. Throughout my career, I have used Core Graphics, OpenGL, SQLite, Core Data, JSON, XML etc. I am very proficient in many design programs including Photoshop, Illustrator, Flash, iMove. Although I am very knowledgeable in all Adobe Products. Most the time i am designing my apps without taking help from any graphics designer. I love to make app from my designs. It feels great when you are creating app from scratch and no body else is involve in your ideas. You are free to do anything. As the Senior Developer and Team lead at Triffort Technologies, I managed a team of Technical Interactive Developers and Designers. As their manager I am responsible for scheduling, resource management, task reviews, process development and enhancements, employee reviews and new employee hiring. I believe good employee morale and communication are key factors to successful, creative work, therefore, positive feedback was part of my daily routine. But most of the time you can find me on my desk writing codes for some app. I love programming. This is my passion. I’m a team player. I am a motivated individual who enjoys taking on new challenges and learning new technologies. I am well organized and a proficient multi-tasker. I have strong problem solving skills such as the ability to use technology in creative ways to meet unique project requirements. I love to be challenged and I always have a positive outlook no matter how tight the deadline is. If you would like to contact me or find out more about my experience, please contact me at muzammil@triffort.com or you can Skype me at muz.iphonedev.

14 responses »

  1. Greataaaaaatttt post dude… have been scratching my head with same error from past 5 hours….. Thank you so much

    Reply
  2. Thanks buddy. It is good to know that my blog is helping others :)

    Reply
  3. Thanks Guys its working for me :)

    Reply
  4. But when you run same project in erlier version (3.2.5) it won’t work. !!! rather
    1. Open your project in XCode 4.2

    2. Remove libz.1.2.3.dylib from framework

    3. Add new framework libz.dylib.

    4. Run your app in both version

    Reply
  5. @Mogs: libz1.2.5 is only for iOS5. So definitely it won’t work in iOS4.3 or its below version (3.2.5 etc).

    Reply
  6. Ashutosh Pathak

    Hi Muzammil, i am using Flash Builder 4.6 to develop iphone app on windows platform so i want your suggestion that is it right to do this or not and what kind of limitations in this method.

    Reply
  7. @ashutosh
    I have never worked on flash builder. So no idea about this.

    Reply
  8. Apple introduces this lib 1.2.5 only for iOS 5
    So it will work only on iOS 5 device. In others your app will crash…

    Reply
  9. worked 4 me thanks

    Reply
  10. Thanks, Worked a treat for me :)

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 68 other followers

%d bloggers like this: